Back to overview
Maintenance

Emergency kernel patching in progress (CVE-2026-31431)

Apr 30, 2026 at 6:30am UTC  –  May 1, 2026 at 4:17pm UTC
Affected services
EU Central (prg1)

Resolved
May 1, 2026 at 4:17pm UTC

eu-central: all clear, all caught up

Kernel rollout is now complete in eu-central - every node is patched against CVE-2026-31431 and back in service. Non-HA workloads have restarted, HA workloads stayed online throughout the process.

With this, all regions are now running the latest kernel versions and fully protected against this vuln.

Thanks for your patience while we pushed this through, and apologies for any disruption the emergency maintenance may have caused.

Updated
May 1, 2026 at 4:17pm UTC

Maintenance ended

Updated
Apr 30, 2026 at 1:32pm UTC

Update — Kernel patching (CVE-2026-31431) is taking longer than originally estimated. We're deliberately pacing the rollout to minimize service disruption. Us-east complete; Central Europe in progress.

Updated
Apr 30, 2026 at 10:33am UTC

Update — us-east complete

Kernel patching (CVE-2026-31431) is complete in us-east. All nodes have been rebooted onto the patched kernel and services are operating normally.

Created
Apr 30, 2026 at 6:30am UTC

A Linux kernel vulnerability allowing local privilege escalation requires immediate patching of all platform hosts. Nodes will be rebooted sequentially.